About twitter.com supported browsers

We officially support versions of the following browsers from the past year on twitter.com:

If you use Twitter on an older version of the above browsers, browsers not listed, or a browser extension which modifies your user agent, you may be unable to use Twitter. In order to ensure the best possible Twitter experience, including all the latest features and security updates, please make sure your browser and operating system are up-to-date.


Please note that compatible browsers are included with most operating systems:

  • Windows 10 - Edge
  • Android - Chrome
  • MacOS / iOS - Safari

Share this article

Better site: ProxyBot webproxy https://proxybot.cc/b?q=2duYT8n1XnnuF8s6oSuiSCBXiUVn1XnnuFSn1XnnuFVBCTT6FnuaVjF61BuFB